Env Touch and Bitpim

edited July 2009 in enV Touch General
I just got my Env Touch a wekk ago and for the past few days I've been trying to get it to work with Bitpim and have had absolutely no luck. No matter what LGmodem drivers I use, which version of BitPim, or what OS it's always the same. I've tried Windows XP, Vista, and 7 each with similar results. Here is what I'm doing.

1. Installing the latest drivers which has the filename LGUSBModemDriver_Eng_WHQL_Ver_4.9.4_All.exe.

2. Downloading the current version of Bitpim or one of the test builds.

3. Load up Bitpim and choose the VX10000(Voyager) as my phone to detect and then choose the "LGE CDMA USB Modem" as the device I want to use.

4. Go to the Filesystem tab and click the [+] and wait. It says it's retrieving but ends up returning nothing after I wait around 10 minutes for the busy message to go away.

Sometimes it gives me an error of "COM#: could no open port: (5, 'CreateFile', 'Access is denied.') When that error is not given the error in the log file is:
LG-VX10000: No response to AT+GMM
Failed to read filesystem
COM#: Write Exception: (995, 'GetOverlappedResult', 'The I/O operation has been aborted because of either a thread exit or an application request.')

Anyone who has gotten Bitpim to work with their Env Touch have any idea whats going on or can just post their steps to getting it to work?

Comments

  • Well I just tried it with a few other phones. Bitpim works fine with an Env2 and one of my friend's Voyagers. However I did notice that when I plug the Touch in windows tries to install 3 devices and two out of the three install and the other "Fails" installation. The device is randomly just one of the three being installed, so it's not the same one.

    On another note, I can't do much of anything with Bluetooth. Once I pair the phone with my Laptop it keeps telling me I need to provide the installation disk that came with the device. My Bluetooth works with other Bluetooth peripherals. Any idea where I can locate the Bluetooth drivers for the Env Touch?
  • I got the Lg Env Touch to work with Bitpim version 1.07. My tutorial is under env touch Tip and Hacks.
  • I haven't had my envTouch a full month yet, and as much as i love this phone, there are a few things about it that i don't... so i googled "envtouch hacks" and came across this site. This my first phone outside of the motorola box... I'm familiar with bitpim as i used it when hacking/modifying my motorola phones, but when trying to get bitpim to find my touch, i get all of the above mentioned problems. I've tried different drivers, different settings, but still nothing. I Tried the DUN trick and it worked fine, i would like to try the vz navi app trick but i cant get bitpim to read my phone. If anyone has any idea as to what I'm doing wrong or should be doing and can help i would greatly appreciate it.
  • I probably should have updated the status earlier but I at one point called LG about this issue and they said that a lot of people are having issues with their drivers and it is a known issue that they are working on. So, if you can't get your Touch to work with your PC through the USB cable then it might just be some issue with your computer and the drivers and not your phone and computer.

    That being said, I did have a lot more success with Bluetooth. So if your computer has Bluetooth support or you can get a cheap Bluetooth dongle than that should be sufficient. Make sure your bluetooth drivers/software is up to date so that it can successfully communicate with your phone. After that choose the lowest COM port that is for Bluetooth connections in Bitpim. It's a little slower than USB but it still works well.

    If you don't have any way to get Bluetooth working with your PC then you'll just have to wait it out for LG to come through.
  • Thanks for the help, i finally got it to work, I don't know what exactly helped but it works now... I changed dongles and tried each com port. Now if i could get the vz navi trick to work id be set.
  • I can't get the phonebook to load.

    Every else works but I get an "Exception Error" trying to load phone bokk.

    I used above driver but I am running vista.

    Heres what I get:

    BitPim version: 1.0.7.20090722-Test
    An unexpected exception has occurred.
    Please see the help for details on what to do.

    Traceback (most recent call last):
    File "gui.pyo", line 284, in run
    File "gui.pyo", line 159, in __call__
    File "gui.pyo", line 1906, in getdata
    File "phones\com_lgvx11000.pyo", line 102, in getphonebook
    File "phones\com_phone.pyo", line 151, in readobject
    File "phones\com_lg.pyo", line 1703, in _filefunc
    File "phones\com_brew.pyo", line 972, in getfilecontents
    File "phones\com_lg.pyo", line 1703, in _filefunc
    File "phones\com_brew.pyo", line 1124, in statfile
    BrewNoSuchFileException: No such file

    Variables by last 8 frames, innermost last

    Frame __call__ in gui.pyo at line 159
    self =
    args = ()
    d = Keys []
    {}
    kwargs = Keys []
    {}

    Frame getdata in gui.pyo at line 1906
    count = 1
    i = (
  • Credit goes to Charim from another website who provide these instructions...after 3 days of working at this, my env touch finally syncs with bitpim!!

    For those of you still having issues with the enV Touch, sometimes you have to see if there is a setting wrong in the phone. Please ensure you only change things that you can fix later.


    I was having issues connecting my phone to Bitpim, version 1.0.7, running Ubuntu 10.04. However this may apply to any OS running bitpim to connect to your mobile device.Also, my phone firmware is a higher revision than the one which Bitpim 1.0.7 was tested on. Mine was VX11KV04 and the tested firmware was VX11KV03. I am guessing that this setting was changed with the firmware upgrade to keep us from using third-party software like Bitpim.

    We are going to access the service menu on your phone. Go ahead and dial this number.
    Quote:
    ##service
    or
    Quote:
    ##7378423
    Then hit send. For the letters, it is just like dialing any other number, like 1800callme=1800225563.

    It wont dial a number, instead a menu will pop up that says "Test Mode"

    From this menu, hit the clear button. You will see another menu labeled "ServicesLG".

    Choose the "Data-LG" Option from the menu.

    Ensure that "PortMap(Data)"="USB CDC" and "PortMap(Diag)="USB Diag".
    On mine, the "PortMap(Diag)" was originally set to "NULL Dev", hence keeping me from accessing it.

    You should be able to leave the menu after changing the setting, and bitpim should be able to detect your phone!!
  • it says i need to insall a driver? but it wont let me cause i dont have a cd that came with my phone? wich i didnt get cause mine was a trade for the samsung rogue cause they didnt make that phone anymore.
Sign In or Register to comment.